Fandom

Community Central

Admin Forum:Strange glitch caused by message wall and rc feed

19,033pages on
this wiki
Add New Page
Talk0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.

This Forum has been archived

Forums: Admin Central Index Technical Help Strange glitch caused by message wall and rc feed
Wikia's forums are a place for the community to help other members.
To contact staff directly or to report bugs, please use Special:Contact.


I noticed really strange bug. I already have reported that to the Wikia staff but I think I might write here, too. This glitch was caused by Recent Changes feed ({{Special:Recentchanges/30}}) on my Main Page exactly when Message Wall edit had appeared on it. This glitch caused <mainpage-leftcolumn-start /> and <createbox> tags to be replaced by string of nonsense characters, thus breaking the layout. I checked on another wiki I'm admin on, and that glitch appeared after Message Wall edit too. Poll extension tags also seems to break after this. I have replaced the mainpage tags with normal div tags, but createbox still doesn't work. This wiki is w:c:pl.yugioh. What do you think about that issue? Have something like that happened to any of you? Final Cannon Dyskusja 14:10, August 20, 2012 (UTC)

I had the same problem on a page where I'd put {{Special:Newpages}}, but it had nothing to do with Message Wall since Message Wall wasn't enabled on that wiki. I suggest you Special:Contact/bug that. --Category:Ciencia Al Poder (talk) -WikiDex 14:30, August 20, 2012 (UTC)
Good that this doesn't happen only to me. I have already contacted wikia by standard contact form. I just assume that this is related to Message Wall, because I have Recent Changes transcluded on the three wikis I manage, and that bug have happened only on the two where the Message Wall is enabled and exactly when it appeared on the recent changes. I purposely edited message wall on one of these wikis to confirm that - glitch occured just after that. Final Cannon Dyskusja 14:44, August 20, 2012 (UTC)
Did the string of characters look something like that - UNIQ7fda1a8fcf18922-mainpage-leftcolumn-start-00000000-QINU ? Sovq 15:44, August 20, 2012 (UTC)
Yes, these characters look like that. Final Cannon Dyskusja 16:05, August 20, 2012 (UTC)
Every now and then I stumble across this bug. I know it has been reported earlier and is waiting for a fix. It seems to be caused by WikiActivity and RecentChanges feeds which don't seem to play well with some other tags. Good news is that you can temporarily (until this gets fixed) work around this issue by removing Thread namespace entires from the feed, which is done either by <activityfeed exclude="thread" /> for activity feeds or by {{Special:Recentchanges|namespace=1201|invert=1}} for RC feeds. Bad news is that the latter will not work in wikis which are not yet on MW 1.19. Sovq 20:27, August 20, 2012 (UTC)

(reset indent) Well, bad news is that one of these wikis is actually not upgraded to MW 1.19 yet. Is there another way to work around this or I must patiently wait until Wikia fixes this (or when the upgrade will be done)? Final Cannon Dyskusja 20:38, August 20, 2012 (UTC)

Well, at least that worked on the another wiki - MW 1.19. one. Final Cannon Dyskusja 20:41, August 20, 2012 (UTC)
This is more of an issue with MediaWiki rather than a Wikia-specific problem. I don't know of any other workaround than the one I mentioned above, but I'm sure Wikia's tech team is trying to solve this issue. Seeing as it's often hard to reproduce, as the feed contents change all the time, every report about it is useful to track the cause of it. Sovq 21:08, August 20, 2012 (UTC)
Okay. I wait for the response from Wikia, then. Maybe they will track down the cause of this bug and eliminate it. Thanks for the help. Final Cannon Dyskusja 22:12, August 20, 2012 (UTC)

Also on Fandom

Random Wiki