Wikia

Community Central

Firefox 4 Editing problems

93,584pages on
this wiki

Forum page

This Forum has been archived

Visit the new Forums
Forums: Index Community Central Forum Firefox 4 Editing problems
Wikia's forums are a place for the community to help other members.
To contact staff directly or to report bugs, please use Special:Contact.
Note: This topic has been unedited for 1294 days. It is considered archived - the discussion is over. Do not add to unless it really needs a response.

I can't edit wikis with the Firefox 4 Beta. When I click an edit link the page is blank between the "Back to Page" link and the Summary Box. Also the publish and review buttons don't work.

It has worked only twice in about 50 tries, which is what makes it really weird. It almost seems like the editor just doesn't load for some reason. I have reported the problem to Firefox but want to post it here to see if you guys know how to fix it.

Everything's updated, I'm running Windows XP and Chrome and Internet Explorer seem to work fine when editing wikis. (I'm using Chrome now). Any suggestions? Fulano5321 20:08, March 17, 2011 (UTC)

Have you tried clearing your cache? RandomTime 20:23, March 17, 2011 (UTC)
Just tried clearing it, didn't help, but it was almost 400MB. Don't know why in the world they think such a huge cache woudl help. The first page I tried to edit worked but it didn't work anytime after that. Fulano5321 20:31, March 17, 2011 (UTC)
Check your cache again. If it's back up at a high number, your settings might be causing the problem.  Monchoman45  Talk  Contribs  Skystone  20:33,3/17/2011 
The cash was 2.9mb when it didn't work the second time, I tried clearing it again and restarting Firefox and it still didn't work. I also noticed when I click a link to a page that isn't created Firefox 4 doesn't bring up the new page dialogue at all, it just goes to the edit page and doesn't load the editor. Just in case that was a clue to why it wasn't working. I am suspectecting it is a problem with Firefox 4 itself. Hopefully they'll fix it in the next release candidate. Fulano5321 20:51, March 17, 2011 (UTC)
That's possible too. You might also want to see if staff know anything by asking via Special:Contact.  Monchoman45  Talk  Contribs  Skystone  21:12,3/17/2011 
"the recently released Firefox 4"
Are you sure that you are using firefox 4? From what I can see there is no such thing yet.
If you are using beta software then don't complain when it breaks stuff.
 Nidek   (Talk)  309 edits made 
I was wrong earlier, I guess I could edit it since this IS a wiki and not a forum. It is a beta and it's not so critical that it works because I can use the current release. I'm just trying to identify and solve problems before it gets released. Mostly pointing it out so the devs here could check it out and see if they needed to get something fixed. I'd be a pain to have thousands of Firefox users suddenly not be able to edit wikis if the bug wasn't fixed when they released it. Thanks for the concern though. Fulano5321 02:33, March 18, 2011 (UTC)
I've noticed an identical issue in Firefox 3.6. I did manage to solve my issue - it was caused by an add-on script blocker, which blocked scripts coming from www.nocookie.net. While scripts from that server are blocked, the edit box does not appear. Allowing scripts from said server makes the edit box reappear. Is it possible that Firefox 4 Beta blocks third-party scripts automatically? Maybe you can try looking through the browser options to see if that feature (or any similar script-blocking feature) can be disabled. --Headrock 01:38, March 18, 2011 (UTC)
Beta software is likely to break or bug at any time. It's beta software - eg. not yet finished. You can't expect it to work all the time. You should report this to Mozilla, and wait for them to fix it.  Monchoman45  Talk  Contribs  Skystone  01:50,3/18/2011 
@Headrock: I'll check into that
@Monchoman: It is reported, and it looks like something they will need to fix.
Fulano5321 02:33, March 18, 2011 (UTC)
Make sure to report the issue to Wikia also. Just because FF4 is beta doesn't mean its a FF4β problem. -- Fandyllic (talk · contr) 18 Mar 2011 8:13 AM Pacific
I had this problem with all of the FF4β releases but it appears to be fixed with the FF4 RC2.
Weatherman22 12:45, March 22, 2011 (UTC)
Looks like it's working here. Fulano5321 15:54, March 22, 2011 (UTC)

Update From Wikia Staff

Users with Firefox 4 should now be able to edit the site just as on Firefox 3; this fix went live a few hours ago. The issue was that some JS changes in FF4 meant the browser did not recognize some basic functions on Wikia, such as the edit window.

Alpha/Beta/RC browsers are very tricky to handle because obviously we want to make sure that when they are released that they are compatible with our site, but then again our techies have to weigh that against other important bugs. Technically, our site does not yet support Firefox 4 because it has not been officially released and thus the user group is very, very small. And, of course, conversely we need to know about these issues ahead of time because we can't just flip a switch to make our site browser compatible.

In other words, use beta browsers on Wikia at your own risk. If you love testing beta browsers (and I personally am someone who does) and see something not working, please, as always, contact us. Just be prepared to have to use an older version or a different browser on Wikia as a fallback if you are beta testing. --daNASCAT WikiaStaff.png (help forum | blog) 21:05, March 22, 2011 (UTC)

Hey there, I'm Bureaucrat at swg.wikia.com. I've noticed this issue yesterday with Firefox 4, but with the Final release (not a Beta or RC release). I can confirm that the mentioned patch did fix the issue as expected, but I had to clear my browser cache FYI. Thanks for the prompt fix! --SWG-Warcryer 22:32, March 22, 2011 (UTC)
Thanks for the update. My firefox 4 now runs smoothly. Thanks again, JaidynM (Talk) - (Blog) 06:07, March 23, 2011 (UTC)
I never experienced issues (because of the skins I use?) during the beta stage of Firefox 4 but good to hear it should work now for the others too (: –Tm_T (Talk) 10:07, March 23, 2011 (UTC)
FF4 is now officially released, so the beta excuse goes away. An update from staff about compatibility fixes status would be helpful. -- Fandyllic (talk · contr) 24 Mar 2011 6:21 PM Pacific
The main fix (to the edit window and skin components) went live Monday and as far as I know all FF4 issues are fixed. Please contact us with any new bugs. --daNASCAT WikiaStaff.png (help forum | blog) 15:39, March 25, 2011 (UTC)
If we get more problems that seem to be tied to FF4, we'll try to consolidate them in a sticky post. -- Fandyllic (talk · contr) 25 Mar 2011 8:57 AM Pacific
I had an issue in FF4 too, in which I have contacted Wikia about. For anyone that is interested, this thread on The Sims Wiki contains the relevant information. GG (talk) 17:06, March 25, 2011 (UTC)

(Unindent)I recently upgraded today and have a problem with the drop down menus. The drop down menus, especially the wikia global header, stick for a long time. I never had this problem in 3.6 but now every time I mouse over one of the drop down menus, the menu stays down for close to 30 seconds after I moved my mouse away. Should I switch tabs while a menu is down, the menu stays down until a few seconds after my return to the tab.--GodPray  07:16,3/27/2011 

I upgraded jsut now and I'm having problems editing still. I also started having issues with 3.6 and I thought maybe upgrading to FF4 may help. I did clear my cache, but nothing changed, so I'll do it again. It also doesn't work on internet explorer either, so I went back to 3.6 and still nothing is happening. Is there something going on that I don't know about? MC CJ 03:17, April 6, 2011 (UTC)

Please put your FF4 issues in new sticky post

Forum:FireFox 4 problems and oddities. -- Fandyllic (talk · contr) 28 Mar 2011 2:24 PM Pacific

Around Wikia's network

Random Wiki